vesting contract account is unavailable

hey guys,
i deployed bonfida vesting contract to mainnet and create vestings with cli and get my seeds. so after I went to Bonfida UI and enter any seed it showed error

this is my program id: 82BqM1yhxctuyJpiLhseiakxiottP4AAmP25QTW4vFmB

2022-03-07_17-42-45

any idea?

The UI only works for the official mainnet program ID CChTq6PthWU82YZkbveA3WDf7s97BWhBK4Vx9bmsT743

Forks and custom deployments will not be supported on the UI.

1 Like

ah, i cant find this important information on github and in your website. so if we want to use official contract and not customized one, we can see seed information on UI and transfer it to someone else and also unlock it, right?

and is there any limit for number of vesting parts for any spl-token to create on official contract you mentioned?

The program ID is in the JS client of the Github repo but I will add it to the main README for clarity.

Yes, if you use the official deployment you can do all these on the UI. There is no limitation of that sort.

1 Like

i create vesting with official bonfida vesting contract with this program id:

after that I went to bonfida UI and enter my seed but I saw error again like picture.

i check my seed with cli and it showed information without problem.

any idea?
2022-03-10_19-54-02

Can you copy paste the seed and tx?

tx
3ze6mPeextAnBCKNyKPGa6fjuZLXo4SrMZJDns2V6bdrBmLq83YCvXFvwX2tPwzitZhVv8a8dG25ifdEXwJc5mJB

seed
3xkwSnviKnnQySHsPCiePmo4PRrv4oUthAa59aeniQAa

vesting account pubkey
1JXqQwy1W3EtT2kxJ9yCZH9TYPDXkYzQY4x1GwHGwA5

Looking at the tx, the correct seed is 2c000000000000000000000000000000000000000000000000000000000000ff

and I could trigger the unlock with no issue Explorer | Solana

To get the seed:

  const txInfo = await connection.getConfirmedTransaction(
    "3ze6mPeextAnBCKNyKPGa6fjuZLXo4SrMZJDns2V6bdrBmLq83YCvXFvwX2tPwzitZhVv8a8dG25ifdEXwJc5mJB"
  );

  console.log(
    txInfo?.transaction.instructions[2].data.slice(1, 32 + 1).toString("hex")
  );
1 Like

let me tell you something

i try another token with another vesting schedule, so after I get one seed from cli, I try your instruction and after I find seed in solscan with your point, I use that with bonfida UI and nothing special happened and UI said contract unavailable again.

after that i review “create” command export seed like this:

The seed of the contract is: 42fM6HeoDdH8P8Qqthz6HhYHeSRgmkaoH2sxemxnSCpt
Please write it down as it is needed to interact with the contract!
The vesting account pubkey: 2KeEaHxSdXLMWnD9T44ypvEbLreL1D7E5f7VvnTRMGSJ

i tried seed and i saw error
so i tried 2KeEaHxSdXLMWnD9T44ypvEbLreL1D7E5f7VvnTRMGSJ as vesting account pubkey and yeah, finally i saw the result for the first time.

so please add this info to your github too, thank you

and another point

i click on unlock button and again I saw this error
2022-03-12_13-10-47

it searched for irreverent contract with this pubkey:
FwV3Kwwg5QqmSErfZhGcmigJ8pNHqnTHWktSHqHCXLj4
why?
2022-03-12_13-27-33

You need to enter the contract seed to unlock the tokens not the pubkey of the vesting account

1 Like