Problem bidding on own domain. Bug?

I registered a domain, but when submitting a bid, I get a transaction error:

" Error submitting bid Error: Transaction was not confirmed in 30.01 seconds. It is unknown if it succeeded or failed. Check signature … using the Solana Explorer or CLI tools."

Checking the transaction it’s listed as successful though, at least for the SOL transaction fee, but no FIDA leaves my wallet which I have verified also on Solscan.

I have tried to make a bid with two different phantom wallets, using the required FIDA tokens, I have enough SOL to cover gas also.

It’s currently under auction, listed as “unavailable” owner: root-tld" 0 bids. About 1.5 days left to figure this out before the auction ends.

I’m still learning this space, so I’m unsure if I’ve encountered an issue, or I have performed a step incorrectly.

any help appreciated

Can you give a tx id or let us know what domain you are talking about?

thanks for the speedy response. the domain is: “jonpxl.sol”

I just tried to place a bid on it and I confirm it works on my end.

A few questions:

  1. What wallet are you using?
  2. Do you have enough SOL for gas?
  3. Do you have enough FIDA?

That’s good I suppose.

  1. Phantom. I’ve tried both with my usual phantom and my ledger account

  2. Yes both accounts have enough sol for the fees

  3. I think so the auction says 8.171 FIDA minimum bid, I have about 8.4 FIDA

I have also tried to bid using phantom on different browsers with no luck. The wallets themselves seem to be working as I have used them with Raydium to obtain the FIDA, and regularly transfer between the two wallets without issue.

I also then tried via twitter handle, but again got some error message when posting the url to the tweet. Perhaps because it was already under auction? or maybe that’s unrelated? So I’m struggling to obtain a domain however I try.

I saw your bid. I don’t have over 9 FIDA, so I would have to go back to Raydium to get more, with more fees, with no guarantee a bid would work.

Do you mind sending a tx id?

Hi,

Sure. Like I mentioned, I’m still learning a few things. Hopefully this is what you mean:
4NtLjWQiQa2cobmdBSsxU6vGWeUoCQ54b3ibwUk3NwEXzSYK2mf7pRd2fVfZ8eAsK1CummDDwMjy9TnwSVAqQTS5

That’s a tx for initialising the bidder pot account. Do you have the tx where you are placing a bid?

I go to: /#/domain/jonpxl, click bid, with my funded phantom wallet connected, and then I get the error message pasted above with an address. Here are the records: Solscan
I don’t know if I should be doing something other than clicking on bid? As mentioned, I have the same with either wallet I use. Thanks for helping me promptly. Hopefully we can get to the bottom of this before the auction expires.

i lost a lot of sol the other day because of this error. Bonfida doesn’t have their accounts set up properly so the users just lose sol instead of having it returned.

Hi, thanks for taking the time to chip in. So did you just give up, or did you manage to obtain your domain in the end? It’s frustrating that they can’t replicate the problem, and were able to place a bid on my domain without issue. Being left out of pocket is not a great way to start dabbling in defi.

This is because of the way the devs structured the contracts, it uses 2 accounts which is the incorrect format. So every time there is an error the users are charged and we lose sol. It should be set up so we actually are refunded the sol for creating the account and only lose out on the transaction fee. the .00005 or w/e. If you go into the solana discord and show them the TX they will confirm this. They are using outdated code essentially.

Thanks. So this would explain the fee during errors, but the reason for the error is still a mystery :frowning: Think I’m going to have to give up and wait till this feature functionality matures or is provided elsewhere

There is a growing group looking to do the same thing.

1 Like

@SolOnARoll This is the standard way of doing with the Metaplex auction program. There are two accounts: bidder pot account and bidder pot token account.

@Jupe Do you have an example of the tx that fails? I cannot replicate what you are describing on my end.

The auction program is pretty expensive then. Why can’t we have both, auction and static then let the market decide which style they desire. We’re asking for listing on ME without a mirror because we want their style of auctions without the mirror because of the auction style lol.

Basically what happens is if you bid and the network is experiencing rpc issues because of raydium, you bid, the tx is a success but no fida leave your wallet but you’re still charged the .002. When you think about it this method is pretty expensive to bid on something you probably have a low % chance of winning, then to list the auction u have to pay the fee again.

@SolOnARoll What you are saying is inaccurate:

  • The Solana RPC connection uses a preflight check to guarantee that tx that will fail are not sent to the network, therefore no SOL is debited.
  • When Solana is experiencing degraded performances and that tx are dropped by the validator no SOL is debited.

The only cost comes from the two accounts required for bidding:

  • Bidder pot account (97 bytes) which is a PDA and allocated only once.
  • Bidder pot token account (165 bytes) allocated at the same time of the bidder pot account so also allocated only once.

@bonfida I used your telegram support (wild west with not knowing who’s a scammer and who’s not), and after lots of trial and error, managed to get it to work.

What got it to work (at least on one occasion):

  • changed from Edge browser to Chrome
  • have more than 0.1 SOL in my phantom wallet
  • turn on auto trust for bonfida

All of these in isolation didn’t work, but in combination did. I can’t say with any certainty what’s luck and what is a requirement. I was a bit surprised at needing that much SOL in my wallet, but this was recommended by the support in the telegram. I prefer to keep minimal amounts in my hot wallet and not use auto-trust on services I’m using for the first time.

I do have a screenshot of the error (support kept asking for a screenshot rather than the text, and I no longer have the text copied somewhere) I don’t know how the forum handles in thread images, hopefully it can be expanded and readable.

As @SolOnARoll was saying, I do indeed have SOL debited from my account on all the failed transactions. 0.00001 most the time, but the odd 0.00005. I know these are insignificant amounts, but just letting you know. My wallet: Hbytsg44SyzZyAJzR47vEi2YXAYYVfTQHFC1hAmYcGkA

Happy to provide any more details that can help make the service a smoother experience in future.

1 Like

You are taxed .002 every single time it succeeds but does not go through. You are the one who is wrong. @bonfida