Host Bonfida UI : Error when try to start my local environment

Hello,
I got error after following this step https://docs.bonfida.org/collection/audaces-perpetuals/host-a-ui and add tradingview charting library + datafeeds. Could you please help me in this error? Here is my screenshot :

bonfida_error

Thank you!

Hey @prazovic !

What do you have in your .env file?

Hi @bonfida , here is my .env content
REACT_APP_USDT_REFERRAL_FEES_ADDRESS=‘C6PxqvLyDArZtLFmBv3e2VRatKbkiJogL66k5yNeni3B’
REACT_APP_USDC_REFERRAL_FEES_ADDRESS=‘C6PxqvLyDArZtLFmBv3e2VRatKbkiJogL66k5yNeni3B’
REACT_APP_ALLOW_REF_LINK=false
REACT_APP_EXCLUDE_MARKETS=[]

The Connection context require you to add some RPC endpoints in your .env file audaces-perps-ui/App.tsx at main · Bonfida/audaces-perps-ui · GitHub

Add something like this for instance:

REACT_APP_CONNECTION=https://solana-api.projectserum.com
REACT_APP_CONNECTION_DEV=https://solana-api.projectserum.com
REACT_APP_CONNECTION_WSS=https://solana-api.projectserum.com

Thank you for the solution. The new problem is chart area keep loading and never shows the chart. Here is the detail:

Failed to load resource: net::ERR_FAILED
:3000/#/trade/ETHPERP:1 Access to fetch at ‘https://serum-api.bonfida.com/tv/symbol_info?group=NYSE’ from origin ‘http localhost:3000’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. If an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.
bundle.js:1 GET https serum-api.bonfida.com/tv/symbol_info?group=NYSE net::ERR_FAILED 403

image

You can DM me I will whitelist your origin